登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

nygxxh的博客

 
 
 

日志

 
 

macd指标公式  

2013-07-10 21:57:42|  分类: 股票公式 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
{xycs小鸭出水xg}
DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26);
DEA := EMA(DIFF,9);
小鸭出水xg:MA(C,30)>=REF(MA(C,30),1) AND DIFF<0 AND DEA<0 AND
CROSS(DIFF,DEA) AND MA(C,5)>MA(C,10) AND MA(V,5)>MA(V,34);
{设计思路:
1.ma30向上;
2.diff,dea在零线之下;
3.diff金叉dea;
4.ma5大于ma10;
5.量均线mav5>mav34;}
---------------------------------------------------------------------
{hdlyxg海底捞月选股}
DIFF := EMA(CLOSE,12) - EMA(CLOSE,26);
DEA  := EMA(DIFF,9);
MACD := 2*(DIFF-DEA);
v1:=DIFF<0 AND DEA<0 AND CROSS(DIFF,DEA); 
v2:=ma(c,5)>ma(c,10);
v3:=VOL>MA(VOL,5) AND MA(VOL,5)>MA(VOL,34); 
v4:=MA(C,30)>=REF(MA(C,30),1);
vv:=v1 AND V2 and v3 AND V4;
xg选股:if(vv,1,0);
{设计思路:
1.30日均线走平向上;
2.5日均线金叉或已金叉或即将金叉10日均线,
2.diff指标线由原来在0轴以下死叉dea线变为在0轴以下金叉dea线。
3.当日成交量大于5日均量线,5日均量线大于34日均量线;} 
----------------------------------------------------------------------
{fsxs佛手向上xg}
DIFF := EMA(CLOSE,12) - EMA(CLOSE,26);
DEA  := EMA(DIFF,9);
MACD := 2*(DIFF-DEA);
vv:=CLOSE>OPEN AND MA(CLOSE,5)>MA(CLOSE,10) and MA(CLOSE,10)>MA(CLOSE,30)
and DIFF>DEA AND MACD>REF(MACD,1) and DIFF>0 AND DEA>0 and
MA(VOL,5)>MA(VOL,34) and MA(CLOSE,30)>=REF(MA(CLOSE,30),1);
xg选股:if(vv,1,0);
{设计思路:
1.ma30向上;
2.diff,dea在零线之上;
3.diff线回调dea线附近时不死叉,又调头向上;
4.ma5大于ma10,ma10大于ma30;
5.量均线mav5>mav34;
6.当日是阳线} 
----------------------------------------------------------------------
{mbqyxg漫步青云xg}
DIFF := EMA(CLOSE,12) - EMA(CLOSE,26);
DEA  := EMA(DIFF,9);
v1:=DIFF>=0 and DEA>=0 and CROSS(DIFF,DEA);
v2:=MA(CLOSE,5)>MA(CLOSE,10);
v3:=MA(CLOSE,30)>REF(MA(CLOSE,30),1);
v4:=VOL>MA(VOL,5) and MA(VOL,5)>MA(VOL,10);
vv:=v1 and v2 AND V3 AND v4;
xg选股:if(vv,1,0);
{设计思路:
1.ma30向上;
2.diff,dea在零线之上;
3.diff线金叉dea线;
4.ma5大于ma10;
5.量均线,v>mav5,mav5>mav10;}

  评论这张
 
阅读(347)| 评论(0)

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018