登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

nygxxh的博客

 
 
 

日志

 
 

【转载】波段底部组合选股公式(有图有源码无未来)  

2013-04-05 23:16:26|  分类: 股票公式 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

简单说明:已主图黄色买入为基本股票池,其中发出预警信号后可轻仓介入,待趋势走稳后在加仓。
源码如下:
N1:=5;N2:=10;
STICKLINE(C>0,0,10,15,0),COLOR781816;
LLC:=REF(CLOSE,1);
RSI15:SMA(MAX(CLOSE-LLC,0),N1,1)/SMA
(ABS(CLOSE-LLC),N1,1)*10,COLORFF00FF,LINETHICK1;
RSI10:SMA(MAX(CLOSE-LLC,0),N2,1)/SMA
(ABS(CLOSE-LLC),N2,1)*10,COLOR00FFFF;
VAR21:=C-REF(C,1);
VAR22:=100*EMA(EMA(VAR21,6),6)/EMA(EMA(ABS(VAR21),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),0),COLOR0000FF;
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),0),COLOR00FF00;
短牛:(LLV(VAR22,2)=LLV(VAR22,7) AND COUNT(VAR22<0,2)
AND CROSS(VAR22,MA(VAR22,2))) AND
REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
STICKLINE(UP,0,0.2,3,0),COLOR0000FF;
STICKLINE(DOWN,0,0.2,3,0),COLOR00FF00;
STICKLINE(短牛,0,8,2,0),COLOR000088;
STICKLINE(短牛,0,8,1,0),COLOR0000CC;
STICKLINE(短牛,0,8,0.22,0),COLOR0000FF;
DRAWTEXT(短牛,8,'←短牛'),COLOR0000FF;
中牛:REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;
STICKLINE(中牛,0,0.2,3,0),COLOR880088;
STICKLINE(中牛,0,7,1.5,0),COLORAA00AA;
STICKLINE(中牛,0,7,0.8,0),COLORCC00CC;
STICKLINE(中牛,0,7,0.2,0),COLORFF00FF;
DRAWTEXT(中牛,7,'←中牛'),COLORFF00FF;
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
大牛:REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
STICKLINE(大牛,0,0.2,3,0),COLOR008888;
STICKLINE(大牛,0,6,2,0),COLOR00AAAA;
STICKLINE(大牛,0,6,1,0),COLOR00CCCC;
STICKLINE(大牛,0,6,0.2,0),COLOR00FFFF;
DRAWTEXT(大牛,6,'←大牛'),COLOR00FFFF;

LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳买入:=(AV + NEWVOL);
最佳买入选股:=IF(CROSS(最佳买入,0),1,0);
VAR1:=SMA(最佳买入选股,3,1);
VAR2:=SMA(VAR1,3,1),COLOR0000FF;
VAR3:=SMA(VAR2,3,1),COLOR00FFFF;
建仓买点:IF(CROSS(VAR2,VAR3) AND (VAR2<40),1,0* 10000),COLORWHITE,NODRAW;
STICKLINE(建仓买点,0,2,2,0),COLORLINETHICK0;
STICKLINE(建仓买点,0.2,4.0,2,0),COLORLINETHICK0;
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 50);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
最佳买入时机: IF(CROSS(J,3),1,0),COLORYELLOW;
STICKLINE(最佳买入时机,0,1,3,0),COLOR009999;
STICKLINE(最佳买入时机,0,1,2,0),COLOR00DDDD;
STICKLINE(最佳买入时机,0,1,1,0),COLOR00FFFF;
机构建仓: IF(最佳买入<5,1,0),STICK,COLORFF00FF,LINETHICK1;
机构建仓日:STICKLINE(机构建仓,0,-0.3,3,0),COLORFF00FF,LINETHICK6;
HIGHN:=5;
RSII:=SMA(MAX(C-LC,0),12,1)/SMA(ABS(C-LC),12,1)*10,COLORCYAN,LINETHICK1;
LOWN:=HIGHN;
AAA:=REF(RSII,HIGHN)=HHV(RSII,2*HIGHN+1);
QY:=BACKSET(AAA,HIGHN+1);
CCC:=FILTER(QY,HIGHN) AND RSII=HHV(RSII,HIGHN+1);
DRAWICON(CCC,RSII*1.02,2);
DDD:=BARSLAST(CCC);
GDTS:=IF(CCC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(RSII,DDD),RSII);{顶部}
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
AA1:=REF(RSII,LOWN)=LLV(RSII,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND RSII=LLV(RSII,LOWN+1);
DRAWICON(CC1,RSI*0.098,1);
 

 

 

  评论这张
 
阅读(317)| 评论(0)

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018