登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

nygxxh的博客

 
 
 

日志

 
 

单阳不破两公式  

2013-02-16 21:53:50|  分类: 股票公式 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
单阳不破两公式(非原创)
 

  勇攀高峰老师在讲课中,提到了一种K线形态,叫做“单阳不破”。这里给大家提供2个有关“单阳不破”的公式(通达信),方便大家学习。(感谢原作者!)

1、是勇攀高峰老师在讲课中给出的,这是非常好的选股公式,调节参数,可以分别选出不同强弱的强势股(经wen98修改)。强弱设为一般时,甚至可选出回踩攻防线的情况;

{单阳不破选股公式}
{设置参数: N1:最小0,最大1,默认1 , N2:最小0,最大1,默认0}
{选股开关: 最强N1: 1开0关,较强N2: 1开0关
1.最强选股:最强设置为1,较强设置为0(N1=1,N2=0)
2.较强选股:较强设置为1,最强设置为0(N1=0,N2=1)
3.一般选股:最强设置为0,较强设置为0(N1=0,N2=0)}

阳涨幅:=5;{可自调4%-10%}
阳倍量:=1.90;{王子倍量倍数}
单阳:=C>O*(1+阳涨幅/100) AND VOL>REF(VOL,1)*阳倍量;
前N天单阳:=BARSLAST(单阳);
高不破价:=REF(C,前N天单阳);
中不破价:=REF((C+L)/2,前N天单阳);
低不破价:=REF(L,前N天单阳);
{两天:=LLV(L,前N天单阳)>=低不破价;}
最强:=LLV(L,前N天单阳{-2})>=高不破价;{后面N天最低价高于在阳收盘价}
{G:= 最强=N1;}
较强:=LLV(L,前N天单阳{-2})>=中不破价 AND 最强=0;{不含最强}
{Z:= 较强=N2;}
一般:=LLV(L,前N天单阳{-2})>=低不破价 AND 较强=0  AND 最强=0;{不含最强和较强}
强弱:=IF(N1=1,最强,IF(N2=1,较强,一般));

选股: 前N天单阳<9 {AND 两天} AND 强弱 AND V>0;

2、是自己以前收藏的主图公式(蓝色部分根据勇攀高峰老师在讲课中视频出现的情况增加30日均线):

{通达信单阳不破主图公式}
MA30: MA(C,30 ),COLORGREEN;
MA30_: IF(MA30>=REF(MA30,1),MA30,DRAWNULL),COLORMAGENTA;

阳涨幅:=4;{可自调4-10}
阳倍量:=1.90;{王子倍量倍数}
单阳:=C>O*(1+阳涨幅/100) AND VOL>REF(VOL,1)*阳倍量;
LS0:=BARSLAST(单阳);
不破价:=REF(L,LS0);
DRAWTEXT(单阳,L-L*0.02,'阳'),COLOR00FFFF;

位置1:=不破价 *0.998;
位置2:=不破价 *0.98;

LS11:=IF(1,LS0=1,单阳);
LS21:=IF(1,LLV(L,1)>REF(L,1),1);
单阳不破:=LS11 AND LS21;
STICKLINE(单阳不破,位置1,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破,位置2,'1'),COLORGREEN;

LS12:=IF(2,LS0=2,单阳);
LS22:=IF(2,LLV(L,2)>REF(L,2),1);
单阳不破2:=LS12 AND LS22;
STICKLINE(单阳不破2,位置1,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破2,位置2,'2'),COLORGREEN;

LS13:=IF(3,LS0=3,单阳);
LS23:=IF(3,LLV(L,3)>REF(L,3),1);
单阳不破3:=LS13 AND LS23;
STICKLINE(单阳不破3,位置1,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破3,位置2,'3'),COLORGREEN;

LS14:=IF(4,LS0=4,单阳);
LS24:=IF(4,LLV(L,4)>REF(L,4),1);
单阳不破4:=LS14 AND LS24;
STICKLINE(单阳不破4,位置1,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破4,位置2,'4'),COLORGREEN;

LS15:=IF(5,LS0=5,单阳);
LS25:=IF(5,LLV(L,5)>REF(L,5),1);
单阳不破5:=LS15 AND LS25;
STICKLINE(单阳不破5,位置1,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破5,位置2,'5'),COLORGREEN;

LS16:=IF(6,LS0=6,单阳);
LS26:=IF(6,LLV(L,6)>REF(L,6),1);
单阳不破6:=LS16 AND LS26;
STICKLINE(单阳不破6,位置1,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破6,位置2,'6'),COLORGREEN;

LS17:=IF(7,LS0=7,单阳);
LS27:=IF(7,LLV(L,7)>REF(L,7),1);
单阳不破7:=LS17 AND LS27;
STICKLINE(单阳不破7,位置1,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破7,位置2,'7'),COLORGREEN;

LS18:=IF(8,LS0=8,单阳);
LS28:=IF(8,LLV(L,8)>REF(L,8),1);
单阳不破8:=LS18 AND LS28;
STICKLINE(单阳不破8,位置1,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破8,位置2,'8'),COLORGREEN;

LS19:=IF(9,LS0=9,单阳);
LS29:=IF(9,LLV(L,9)>REF(L,9),1);
单阳不破9:=LS19 AND LS29;
STICKLINE(单阳不破9,位置1,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破9,位置2,'9'),COLORGREEN;

LS110:=IF(10,LS0=10,单阳);
LS210:=IF(10,LLV(L,10)>REF(L,10),1);
单阳不破10:=LS110 AND LS210;
STICKLINE(单阳不破10,位置1,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破10,位置2,'10'),COLORGREEN;

主图公式效果图:
单阳不破两公式 - nygxxh - nygxxh的博客

  评论这张
 
阅读(370)| 评论(0)

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018