登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

nygxxh的博客

 
 
 

日志

 
 

【转载】“黄金分割率坐标”主图公式(通达信)  

2013-02-01 23:25:27|  分类: 股票公式 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

“黄金分割率坐标”主图公式(通达信) - 以博会友 - 以博会友

“黄金分割率坐标”主图公式(通达信)

  黄金分割率系列——“费波拉奇数列的时间窗口”公式。

  在:“黄金分割率坐标系”主图公式(通达信)中,我们以近阶段(比如一年内)的最低价和最高价为基准,计算出黄金分割率的各个价位;

  在:“黄金分割率坐标2”主图公式(通达信)中,我们以近阶段(比如一年内)的最低价和最高价的高度差为基准,计算出黄金分割率的各个价位;

  这里,我们以近阶段(比如一年内)的最低价和最高价所在日期为基准,计算出黄金分割数(费波拉奇数列)的时间窗口的各个时间点,并在主图显示出来。(费波拉奇数列是指:1,1,2,3,5,8,13,21,34,55,89,144,233,...等。)

  至此,我们的黄金分割率主图坐标系列,已经包含从空间到时间的时空纵横坐标。在下一个贴子,我们把上面几个公式,综合起来,作为总结。

{黄金率坐标系3----以最低价和最高价所在日期为基准}
周期:=N; {是可见的周期数,设为参数N(30,480,240),自己调}
高1:=CONST(HHV(H,周期)); 低1:=CONST(LLV(L,周期)); H_L:=高1-低1;{阶段高低差}
{HH:=H+H_L*0.1;   LL:=L-H_L*0.1;}
顶: 高1,COLORRED,POINTDOT;
底: 低1,COLORGREEN,POINTDOT;
{王子操盘线}
MA6: MA(C,6),COLORGREEN;{178448WEN98编写}
MA6_: IF(MA6>=REF(MA6,1),MA6,DRAWNULL),COLORMAGENTA;
{==========时间坐标====以阶段低点为基准===========}
LTJ:= L=低1;
LSJ:=BARSLAST(LTJ)+1;
L00:=低1+H_L*0.01;
DRAWTEXT(LSJ=5,L00,'5');
DRAWTEXT(LSJ=8,L00,'8');
DRAWTEXT(LSJ=13,L00,'13');
DRAWTEXT(LSJ=21,L00,'21');
DRAWTEXT(LSJ=34,L00,'34');
DRAWTEXT(LSJ=55,L00,'55');
DRAWTEXT(LSJ=89,L00,'89');
DRAWTEXT(LSJ=144,L00,'144');
DRAWTEXT(LSJ=233,L00,'233');
{==========时间坐标====以阶段高点为基准===========}
HTJ:= H=高1;
HSJ:=BARSLAST(HTJ)+1;
H00:=高1+H_L*0.01;
DRAWTEXT(HSJ=5,H00,'5');
DRAWTEXT(HSJ=8,H00,'8');
DRAWTEXT(HSJ=13,H00,'13');
DRAWTEXT(HSJ=21,H00,'21');
DRAWTEXT(HSJ=34,H00,'34');
DRAWTEXT(HSJ=55,H00,'55');
DRAWTEXT(HSJ=89,H00,'89');
DRAWTEXT(HSJ=144,H00,'144');
DRAWTEXT(HSJ=233,H00,'233');

下面是一个效果图:

“黄金分割率坐标”主图公式(通达信) - 以博会友 - 以博会友

(预告:过几天准备发布:前几天的关于黄金分割率的几个公式的综合公式,敬请关注本博!)

 

 

 
  评论这张
 
阅读(209)| 评论(0)

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018