登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

nygxxh的博客

 
 
 

日志

 
 

有精确买点的分时指标  

2012-12-17 08:34:07|  分类: 股票公式 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
TE>有精确买点的分时指标 - nygxxh - nygxxh的博客转载▼TE>
标签:

杂谈

有精确买点的分时指标 - nygxxh - nygxxh的博客

 
 
有精确买点的分时指标


input:N(60,1,111);
a1:=INDEXC;
a2:=INDEXO;
a3:=DISPSTATUS=1;
a4:=BARSLAST(a3);
a5:=(REF(a1,a4))/(REF(CLOSE,a4));
a6:=IF(a3,CLOSE,(REF(CLOSE,a4)));
a7:=IF(a3,(a1/a5),(REF((a1/a5),a4)));
a8:=a6-a7;
a9:=a2/a5;
a10:=INDEXH/a5;
a11:=INDEXL/a5;
a12:=(CLOSE>OPEN)OR((CLOSE=OPEN)AND(CLOSE>(REF(CLOSE,1))));
a13:=(a1>a2)OR((a1=a2)AND(a1>(REF(a1,1))));
大盘:STICKLINE(a13,(a10 +a8),(a11 +a8),0,0),colorRed;
STICKLINE(a13,((a1/a5) +a8),(a9 +a8),5,0),colorRed;
STICKLINE(NOT(a13),(a11+a8),(a10+a8),0,0),colorGreen;
STICKLINE(NOT(a13),((a1/a5)+a8),(a9+a8),5,0),colorGreen;
PARTLINE(CLOSE,CLOSE>(a1/a5),RGB(255,0,0)),linethick2,colorRed;
PARTLINE(CLOSE,CLOSE>(a1/a5)AND(CLOSE<(REF(CLOSE,1))),RGB(255,0,255)),linethick2,colorMagenta;
PARTLINE(CLOSE,(CLOSE>(a1/a5)AND((MA(CLOSE,30))>(REF((MA(CLOSE,30)),1))))AND((MA((a1/a5),30))<(REF((MA((a1/a5),30)),1))),RGB(255,255,0)),linethick2,colorYellow;
STICKLINE((((REF(a1,1))<(REF(a2,1))) AND(a1>(REF(a1,1)))),((a1/a5)+a8),CLOSE,1,1),Color606060;
STICKLINE((((REF(a1,1))>(REF(a2,1)))AND(a1<(REF(a1,1)))),((a1/a5)+a8),CLOSE,1,1),Color606060;
a14:=MA(CLOSE,10);
a15:=(((EMA(CLOSE,5))*7)+((EMA(CLOSE,10))* 3))/10;
a16:=((SMA((MAX((CLOSE-(REF(CLOSE,1))),0)),6,1))/(SMA(ABS((CLOSE-(REF(CLOSE,1)))),6,1)))* 100;
DRAWTEXT(((DATE >700101)AND(CROSS(84,a16))),HIGH,'▼'),colorGreen;
a17:=(((2*CLOSE)+HIGH)+LOW)/4;
a18:=LLV(LOW,34);
a19:=HHV(HIGH,34);
a20:=EMA((((a17-a18)/(a19-a18))*100),6);
a21:=EMA(((0.667*(REF(a20,1)))+(0.333*a20)),4);
a22:=LLV(LOW,120);
a23:=HHV(HIGH,120);
a24:=a23-a22;
a25:=HHVBARS(CLOSE,N);
REF(CLOSE,a25),POINTDOT,ColorFF0000;
突破:FILTER(((CROSS(CLOSE,((REF(REF(CLOSE,a25),1))*1.001)))AND(REF((a25>= 5),1))),10),POINTDOT,linethick0;
STICKLINE(突破,(CLOSE*0.99),CLOSE,5,0),ColorF600A9;
DRAWTEXT((((SUM((突破>0),0))=1)AND 突破),(CLOSE*0.99),'最佳买点'),colorWhite;
DRAWTEXT((((SUM((突破>0),0))=2)AND 突破),(CLOSE*0.99),'次佳买点'),colorWhite;
DRAWTEXT((((SUM((突破>0),0))=3)AND 突破),(CLOSE*0.99),'理想买点'),colorWhite;
DRAWTEXT((((SUM((突破> 0),0))=4)AND 突破),(CLOSE * 0.99),'及格买点'),colorWhite;
DRAWTEXT((((SUM((突破> 0),0))>=5) AND 突破),(CLOSE * 0.99),'突破'),colorWhite;
a26:=(CLOSE<(a1/a5))AND(CROSS(80,a16));
DRAWICON(a26,CLOSE,8);
DRAWICON((CLOSE>(a1/a5)AND(CROSS(a16,17))),CLOSE,7);
DRAWICON((CROSS(a16,10)),CLOSE,7);
DRAWICON((CROSS(90,a16)),CLOSE,8);
DRAWICON((CROSS(CLOSE,(a1/a5))),CLOSE,11);
DRAWTEXT(((IF(((((((COUNT((CLOSE<(REF(CLOSE,1))),8))/8)>0.3) AND(COUNT((a20>a21),3)))AND((REF(LOW,1))=a22))AND(CLOSE>OPEN)),1,0))AND(CROSS(a16,15))),LOW,'★小底'),ColorFF8080;
a27:=DYNAINFO(3);
a28:=SMA(CLOSE,2,1);
a29:=SMA(CLOSE,6,1);
a30:=2*(a28-a29);

流通盘大小:=FINANCE2(37)/1000000*100;
DRAWTEXTABS(280,165,'流通盘大小:'+NUMTOSTRN(流通盘大小,2)+'亿'),LINETHICK1,ColorYELLOW; 
每股收益:=FINANCE2(3);
每股市盈率:=DYNAINFO(39);
每股净资产:=FINANCE2(4);
销售毛利率:=FINANCE2(12);
主营收入同比:=FINANCE2(11); 
净利润同比增长:=FINANCE2(10);
DRAWTEXTABS(170,163,'每股收益:'+NUMTOSTRN(每股收益,2)+'元'),COLOR00FF00;
DRAWTEXTABS(170,180,'每股市盈率:'+NUMTOSTRN(每股市盈率,1)+'倍'),COLORRED;
DRAWTEXTABS(170,200,'每股净资产:'+NUMTOSTRN(每股净资产,2)+'元'),COLORRED;
DRAWTEXTABS(20,165,'销售毛利率:'+NUMTOSTRN(销售毛利率,2)+'%'),LINETHICK1,COLOR00FF00;
DRAWTEXTABS(20,180,'主营收入同比增长:'+NUMTOSTRN(主营收入同比,2)+'%'),LINETHICK1,COLOR00FF00;
DRAWTEXTABS(20,200,'净利润同比增长:'+NUMTOSTRN(净利润同比增长,2)+'%'),LINETHICK1,COLOR00FF00;


有精确买点的分时指标 有精确买点的分时指标
  评论这张
 
阅读(433)| 评论(0)

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018